1. NOTICE: If you are using Fabrik and update to Joomla 3.10, you will need to update to Fabrik 3.10. And, if you are using Fabrik, do not upgrade to Joomla 4, we do not have a supported version ready for release. More information on a release date coming soon. Also, please note that Fabrik 3.10 will not install on any Joomla sites less than 3.8.
    Dismiss Notice

Error 500 using Content type

Discussion in 'Community' started by 7webcreator, Aug 29, 2021.

  1. juuser

    juuser Well-Known Member

    Level: Community
    It's probably a minor thing, but it's hard to say without seeing the actual site.
     
  2. 7webcreator

    7webcreator Member

    Level: Community
    Thank you for coming back to me. Is the Fabrikdebug report not sufficient?
     
  3. troester

    troester Well-Known Member Staff Member

    Level: Community
    It would be helpful if you give the exact element settings, the full element name etc.
    What is shown in details view and in form view?

    BTW: your debug txt doesn't seem to be related to the screenshot of the list you posted.
     
  4. 7webcreator

    7webcreator Member

    Level: Community
    The report is related to the below screenshot.

    upload_2021-9-17_18-4-22.png

    I have issues with all the database join elements below.
    upload_2021-9-17_18-7-38.png
    The setting is what is given by default.
    upload_2021-9-17_18-9-36.png
    Only Allievi and Docenti elements are joined with the Juser table and have a SQL statement on the Where Data tab. Please let me know whether you would prefer to visit the website.

    Thank you

    upload_2021-9-17_18-12-3.png upload_2021-9-17_18-14-17.png
     
  5. lousyfool

    lousyfool Active Member

    Level: Community
    The sub-query in the "Joins where" is very wrong. Please use correct syntax.

    For what you seem to be wanting, you won't need that complicated of a sub-query anyway.
    Something like
    Code (Text):
    WHERE {thistable}.id IN (SELECT user_id FROM j25_user_usergroup_map WHERE group_id = 10)
    should do, I guess.
     
  6. 7webcreator

    7webcreator Member

    Level: Community
    I appreciate your help. Unfortunately, the issue remains. I still get the ID displayed instead of the name. All the database join elements are displaying their respective ID instead of the description. Any other tips to solve this issue?
     
  7. troester

    troester Well-Known Member Staff Member

    Level: Community
    Really no idea. Beside my question in post#11: are all you lists linked to the same database and is this the Joomla database and is the Fabrik connection also pointing to this database?
     
  8. 7webcreator

    7webcreator Member

    Level: Community
    Yes, all the lists are linked to the same database, and it is a Joomla database with a Fabrik connection pointing to it.
     
  9. troester

    troester Well-Known Member Staff Member

    Level: Community
    Is it the same in frontend and backend?
    Is it in all views (i.e. list, form, details view)?

    Do you have any layout overrides (in Joomla template, in Fabrik layouts)?

    What happens if you create a new list with a new databasejoin element?

    Are all your plugins also Fabrik3.10?

    Did you try a GitHub update?

    As always: backup before
     
  10. 7webcreator

    7webcreator Member

    Level: Community
    I have the same issue in frontend and backend. It is effectively in all views.
    I don’t have any layout overrides. I use the template protostar. This list is new and all the elements are newly created. All the plugins are updated to Fabrik 3.10. Only the following plugins are not up-to-dated:

    list example==> 3.0.9
    List filter view==> 3.3.4
    Package ==> 3.0.9

    should I still have to try a GitHub update?
     
  11. troester

    troester Well-Known Member Staff Member

    Level: Community
    I mean one new list with a new database table, without content type (resp. content type = default), adding manually one dbjoin to a simple table , without any Data-where etc.
     
  12. 7webcreator

    7webcreator Member

    Level: Community
    I have created a new list with newly added database join elements, and it is working fine. However, I need to archive a table that contains more than 5000 rows. As I couldn't use the content type = default, I have copied, using PhpMyAdmin, the structure and data to a new database table. Would you mind advising me whether creating a new database table with newly added elements would work by copying the data only?
     

Share This Page